Google Chrome Extension Unavailable

Incident
July 06, 7:59am

Google Chrome Extension Unavailable

Status: in progress
Start: July 03, 11:33am
Affected Components:
Platform
Update

July 03, 11:33am

July 03, 11:33am

Mindful Feedback is currently experiencing an issue with the Google Chrome extension being unavailable. We are working to resolve this as soon as possible and will provide further updates as we know more. Thank you for your patience.

Update

July 06, 7:59am

July 06, 7:59am


Service Update: Chrome Extension Unavailable & Alternative Solution

Status: Investigating / Mitigation in Progress

What’s HappeningFollowing recent Google Chrome Web Store policy updates effective July 1st, our Chrome extensions have been temporarily taken down by Google.

We have submitted an appeal to Google and are awaiting a decision.  Because resolving this requires significant structural redevelopment to align with Google's new framework, our extensions will be unavailable for the foreseeable future. We are currently evaluating available options while we await the decision of the appeal.

To ensure your workflows continue uninterrupted, we have a best-practice, extension-free solution ready for you right now.

How to Stay Connected: Switch to Auto-Transfer The absolute fastest and most stable way to resolve this issue is to activate our Auto-Transfer method. This native feature completely removes the need for a browser extension.

  • Why switch? It bypasses browser-specific restrictions, experiences less downtime, and requires zero local maintenance.

  • How to switch: Configuring automatic transfers to Feedback surveys  or reach out directly to our support team to help you get set up.  *If you do not use Genesys Cloud and are experiencing this issue, please reach out to our Mindful Feedback support team via a new case for investigation.

We sincerely apologize for any inconvenience this policy change has caused, and we are fully committed to getting you seamlessly transitioned to the auto-transfer method today.